华为HCNA 实验笔记

发布于 2019-01-05  1.94k 次阅读


实验1 模式切换
1.system-view 系统模式 quit退回用户模式
2.命令补全Tab 显示当前命令

实验2 配置主机名
1.sysname 新名称

实验3 配置consloe密码
1.user-interface console 0
2.选择密码认证模式 authentication-mode password

实验4 配置console密码
1.user-interface console 0 选择aaa模式 authentication-mode aaa
2.aaa模式下 创建用户 loca-user xx password cipher xx
3.设置权限 local-user xx privilege level 15
访问级 1监控级 2配置级 0-15共16级

实验5 配置接口IP
1.interface 端口 ip address xx 掩码xx
2.查看ip 配置 dis ip interface brief

实验6 配置 telnet
1.console只允许单用户访问 vty可以多个
2.远程管理协议 ssh加密 telnet 明文
3.配置vyt user-interface vty 0 4 同时5用户登录
4.配置认证模式 authentication-mode aaa
5.添加用户aaa, local-user xx password cipher
6.设置权限 local-user xx privilege level 2
7.设置类型 local-user xx service-type telnet

实验7 配置SSH
1.开启SSH stelnet server enable
2.创建加密密钥 rsa loca-key-pair create 默认512 推荐 1024
3.创建用户 进入aaa local-user xx password cipher xx
local-user xx privilege level 2
local-user xx service-type ssh
4.vty配置 user-interface vty 0-4允许ssh登录protocol inbound ssh
5.vty认证模式 authentication-mode aaa
6.认证模式 ssh user xx authenticatio-type all
第一次登录ssh ssh client first-time enable stelnet xx

实验8 查看系统文件
系统文件 设备操作系统 用户模式 dir flash:/
配置文件 设备的配置信息
运行配置文件 dis current configuration
启动配置文件 dis saved-configuration //vrpcfg.zip

实验9 管理文件 FTP
管理文件系统方式 FTP文件传输协议 TFTP简单文件传输协议
ftp-server
1.配置接口地址 interface gigabitethernet0/0/0 // ip add /24
2.ftp server enable
3.创建用户 进入aaa模式 local-user xx password cipher xx
设置权限 local-user xx privilege level 3
设置服务类型 local-user xx service-type ftp
设置ftp目录 local-user xx ftp-dirdctory
ftp-client
1.登录 ftp ipxxx
2.下载文件 get 文件名 新文件名
3.上传文件 put 文件名 新文件名

实验10 ICMP
ICMP internet信息管理协议 :对网络运行状态检测的工具
1.ping 测试ip连通性
2.tracet 路由跟踪 从源节点到目的节点经过的三层节点信息 思科traceroute

实验11 路由直连
1.路由分类 直连路由 静态路由 动态路由
2.配置接口ip
3.查看路由表 dis ip routing-table
4.关闭接口intface xx shutdown 开启端口 undo shutdown

实验12 静态路由
1.手动添加 无法适应网络变动
2.ip route-static xx网段 掩码(目标网络) 出接口(本地去往其他路由) 下一跳(发出后下一三层接口)

实验13 等价路由
1.等价路由:路由器通过路由协议无法比较出优劣
2.设备有多条去往目标网段的路径,并且带宽差异不大可使用等价路由
3.IP route-static xx网段 xx掩码 xx出接口 xx下一跳
ip route-staic xx网段 xx掩码 xx出接口 xx下一跳 同是加入路由表

实验14 浮动静态路由
1.浮动路由 让高带宽链路做主链路,低带宽为备份链路(修改路由的优先级)
2.路由选举比较掩码长度 越长越优 比较路由优先级 越小越优 比较路由开销值 越小越优
3.掩码越长mask:网段越精确 路由优先级pre:不同路由协议的可靠程度 直连0;静态60;RIP100;OSPF 10;开销值cost:描述从路由器本地到目标网段的距离
4.修改静态路由优先级 ip route-staic xx xx xx xx preference(1-255)

实验15 缺省静态路由
1. 缺省静态路由是前缀全0 掩码也全0的路由0.0.0.0/0 代表所有网段
2.ip route-static 0.0.0.0 0 出接口 下一跳(一般用于边界或者出口路由)

实验16 RIPv1
1. 开启RIP 将直连网段宣告进RIP后,RIP会把这些信息封装为RIP协议报文发给邻居路由器,相互学习实现网络互通
2.开启RIP rip 进程号
3.将直连网段宣告进RIP network (主类网段 x.0.0.0)
4.RIP计算开销值 基于跳数 (跨越网段的跳数) 最大为15 超过16认为不可达

实验17 RIP定时器
1.查看RIP display rip
2.更新定时器 update time 30s为周期先邻居发送RIP路由
3.老化定时器180s 没收到路由更新 那么这条路由已经失效
4.垃圾回收定时器 120s 路由被设置失效后 不会立即删除需要在等待120s才会彻底删除
5.rip 会周期性交换信息 因为rip基于UDP udn是不可靠传输 没有确认机制 为了保障路由的可靠更新 所以周期发送
6.进入RIP协议 修改更新时间 timers rip x 更新时间 x老化时间 回收时间(老化时间>邻居更新时间)

实验18 RIP静默接口
1.当路由器的接口被设置为RIP的静默接口后,这个接口将不会再向外发送RIP的组播或广播报文
2.进入 rip协议 silent-interface g0/0/1
3.但路由器对端没有开启RIP的时候 该接口设置RIP的静默接口

实验19 RIP单播更新
1.单播更新是指让邻居路由器间通过单播报文交互RIP路由信息
2.当网络内有路由器没有启用RIP的时候,我们就可以让启用了RIP的路由器使用单播更新,单独交互RIP路由信息,这样就不会影响没有开启RIP协议的路由器
3.开启了RIP的单播更新功能后,RIP的组播或广播更新功能并没有关闭,所以还需要使用静默接口设置,关闭接口
的组播和广播更新功能,这样就只有单播更新功能留下来了。
4.单播 peer 目标地址接口ip 关闭组播和广播 silent-interface g0/0/1

实验20 RIPv2.0
1.进入RIP协议 version 2 宣告网络 network xxx

实验21 RIP自动汇总
1.ripv1 汇总为主类网段 无法关闭
2.ripv2 自动汇总默认关闭 (推荐关闭自动汇总 容易产生路由黑洞和环路)
3.自动汇总:当子网路由传递到主类网段边界的时候,路由器会将子网路由汇总为主类网段再发送出去

实验22 RIPv2认证
1.可以实现接口 明文和密文认证
2.明文认证 进入接口 rip authentication mode simple cipher 密码
3.密文认证 进入接口 rip authentication mode md5 nonstandard cipher 密码 key id

实验23 RIPv2手工汇总
1.可以减少网络中路由条目的数量;可以增强网络的稳定性,
2.进入接口 rip version 2 ; rip summary-adress xx 掩码

实验24 调整RIP版本
1.进入接口 rip version x

实验25 OSPF基础
1.开启ospf 100 进程
2.区域0 area 0
3.宣告网段 network xx 反掩码
4.查看ospf邻居 dis ospf peer
5.查看ospf路由表 dis ip routing-table protocol ospf

优先级:直连0 OSPF10 静态路由60 RIP100

实验26-OSPF修改RID
1.配置OSPF协议
3.修改OSPF的RID:
[Route]ospf 100 router-id 1.1.1.1(RID修改后不会立即生效,需要重启OSPF进程新的RID才会生效)
4.重启OSPF进程:
reset ospf process

实验27-OSPF修改基准带宽
1.进入OSPF协议
2.修改OSPF基准带宽:
ospf 100
bandwidth-reference 10000
单位Mbits/s

实验28-OSPF静默接口
1.进入OSPF协议
2.设置OSPF静默接口:
ospf 100
silent-interface g0/0/1
RIP静默接口不发送组播和广播但是发送单播,OSPF都不发送

实验29-OSPF修改计时器
1.进入接口
2.修改OSPF计时器:
int g0/0/0
ospf timer hello 20
ospf timer dead 60
默认hello 10 dead 40
邻居双方 hello和dead 时间修改相同

实验30-OSPF修改DR、BDR角色
1.修改OSPF的DR接口优先级:
int g0/0/0
ospf dr-priority 0

实验31-OSPF认证
1.配置OSPF接口认证:
int g0/0/0
ospf authentication-mode md5 1 cipher huawei123
2.配置OSPF区域认证:
ospf 100
area 0
authentication-mode md5 1 cipher huawei123

实验32-配置基本ACL
1.配置基本ACL:
acl 2000
rule deny source 10.1.1.1 0
quit
2.调用基本ACL:(出方向接口调用)
int g0/0/1
traffic-filter outbound acl 2000
quit
deny拒绝 permit允许
2000-2999基本ACL 3000-3999扩展ACL

实验33-配置扩展ACL
1.配置扩展ACL:
acl 3000
rule deny ip source 10.1.1.1 0 destination 20.1.1.1 0
quit
2.调用扩展ACL:(出反向入反向都可以调用)
int g0/0/0
traffic-filter inbound acl 3000
quit

实验34-NAT基础
1.什么是NAT技术?
NAT是网络地址转换协议,功能是通过转换报文中的IP地址,实现公私网的互访
2.NAT如何转换报文?
从私网到公网:报文经过部署了NAT技术的路由器时,路由器将报文中的SIP由私网IP转换为公网IP
从公网到私网:报文经过部署了NAT技术的路由器时,路由器将报文中的DIP由公网IP转换为私网IP
3.NAT的技术分类
两大源:源NAT、目的NAT
源NAT:静态NAT、动态NAT、NAPT、easy-ip

实验35-配置静态NAT
静态NAT是公网和私网IP的对应关系是静态的,由管理员手工指定,实现一对一的地址转换
开启NAT:进入出接口
nat static enable
nat static global 转换后 inside 转换前
查看转换表 display net session all

实验36-配置动态NAT
1.定义公网IP地址池
nat adress-group 0 起始IP 结束IP
2.定义私网地址池
acl permit source 10.0.0.1 0.0.0.0 //单独IP
acl permit source 10.0.0.0 0.0.0.255 //网段(反掩码)
3.关联私网、公网地址池
进入接口
nat outbound 2000 adress-group 0 n-pat

实验37-配置NAPT
1.NAPT如何工作?
NAPT实现多对一的地址转换,将多个私网IP转换为同一个公网IP。
在做地址转换时NAPT不仅记录IP地址的转换关系,还要记录端口号的对应关系,这样才能区分不同的私网IP。
2.NAPT如何配置?
NAPT的配置方式和动态NAT类似,只是在最后调用公网和私网地址池时
不加no-pat参数即可。

实验38-配置easy-IP
总结;
1.easy-IP如何工作?
工作方式和NAPT一样,转换后的公网IP为路由器出口的公网IP。
2.easy-IP如何配置?
第一步定义私网地址池;
第二步进入公网接口关联私网地址池。

1.配置接口IP
2.配置easy-IP:
acl 2000
rule permit source 10.1.1.1 0.0.0.0
rule permit source 10.1.1.2 0.0.0.0
rule permit source 10.1.1.3 0.0.0.0
quit
int g0/0/1
nat outbound 2000
quit

实验39-DHCP基础
1.DHCP协议作用?
DHCP是一个C/S架构的协议,通过DHCP协议可以让DHCP客户端从服务器获取到IP等网络信息
2.DHCP的基本工作机制是什么?
第一步:客户端通过广播发送DHCP discover报文寻找服务器端
如果成功 服务器单播发送ack确认
第二步:服务器通过单播DHCP offer报文向客户端提供IP地址等
第三步:客户端通过广播DHCP request报文告知服务器端本地选择使用哪个IP地址
第四步:服务器通过DHCP ack报文告知客户端ip地址是合法可用的
DHCP nak 服务器对request报文拒绝
DHCP release 客户端释放地址来通知服务器

实验40-配置DHCP
1.如何配置DHCP server?
第一步全局开启DHCP;dhcp enable
第二步配置DHCP地址池;
ip poor dhcp1
network 10.1.1.0 mask 255.255.255.0
gateway-list 10.1.1.1
dns-list 10.1.1.1
lease day 2
display this 查看配置
第三步在接口下调用DHCP地址池
int g0/0/0
dhcp select global
quit

实验41-DHCP续约
1.DHCP客户端如何续约?
第一步:当IP地址租期剩余50%的时候,客户端发送单播DHCP request报文向服务器提出续约请求
第二步:如果上一步没有续约成功,客户端则在IP地址租期剩余12.5%时,发送广播DHCP requset报文向服务器提出续约请求
第三步:如果上一步仍然没有成功,客户端将放弃使用现有IP地址,出现发送DHCP discover报文,请求新的IP地址

实验42-DHCP中继
1.为什么要用DHCP relay?
当网络内有多个网段需要使用DHCP服务时,可以通过DHCP relay
技术实现集中管理,方便地址分配。
2.DHCP relay如何配置?
第一步:配置DHCP server,在server上配置客户端对应的DHCP地址池,然后在接口调用。
第二部:配置DHCP relay,在relay连接客户端的接口上开启DHCP relay功能,然后指定DHCP server的IP地址。
3.DHCP relay的工作机制?
配置DHCP relay后,客户端通过广播将DHCP discover报文发给DHCP relay。
DHCP relay在收到客户端的discover报文后,将discover报文重新封装。SIP封装为接收报文的接口IP,
DIP封装为DHCP server的接口IP。
然后将discover报文通过单播方式发向DHCP server。
DHCP server在收到DHCP relay发来的discover报文后,通过单播方式向relay回复DHCP offer。
DHCP relay接收到server发送过来的DHCP offer报文后,将单播offer报文转发给客户端。
4.DHCP server通过什么来判断客户端在哪个网段内?
DHCP server通过DHCP relay发送的单播DHCP discover判断客户端在哪个网段内。因为relay发送的单播discover报
文的SIP就是relay连接客户端的接口IP地址。

 

实验43-链路聚合基础
1.什么是链路聚合?
链路聚合是将多条物理逻辑地捆绑成一条链路的技术,通过这种方式可以提高网络带宽。
2.不做链路聚合设备之间的多条链路就不能同时工作了么?
是的,由于交换网络中通常会运行STP协议,而且STP协议要求设备之间不论有多少条线缆,同时转发数据的链路只能有一条。而我们做了链路聚合后,设备间的多条链路就可以同时工作了
3.链路聚合有哪些方式?
两种:手工负载分担方式、LACP
手工方式:聚合后的所有链路都处于活跃状态,没有备份链路
LACP方式:可以选择活跃链路和备份链路

实验44-配置手工eth-trunk
1.创建聚合链路
int Eth-Trunk 12
trunkport Ethernet 0/0/1 to 0/0/3
quit
总结:
1.配置Eth-trunk接口时需要注意哪些?
第一成员接口最多8个;
第二成员接口在加入eth-trunk前不能配业务;
第三成员接口必须为华为缺省接口类型;
第四eth-trunk不能嵌套;
第五成员接口的带宽必须一致;
第六eth-trunk对端也必须是eth-trunk

实验45-配置LACP方式eth-trunk
1.配置LACP方式eth-trunk:
int Eth-Trunk 12
mode lacp-static
trunkport Ethernet 0/0/1 to 0/0/3
quit
lacp priority 100 设置LACP的主设备
int Ethernet 0/0/1
lacp priority 100 设置LACP接口优先级
int Ethernet 0/0/2
lacp priority 100
int Eth-Trunk 12
max active-linknumber 2 设置最大活动链路数量

实验46-VLAN基础
1.创建vlan10、vlan20:
vlan 10
vlan 20
2.查看设备的vlan信息:
display vlan summary
3.将接口划入对应的vlan:
int Ethernet0/0/1
port link-type access
port default vlan 10

int e0/0/2
port link-type access
port default vlan 20
4.查看接口对应的vlan信息:
display port vlan active
总结:
1.什么是VLAN?
VLAN是一种在交换机上划分逻辑网段的二层技术。
2.为什么要通过交换机划分网段?
第一因为交换机的端口密度比路由器高,并且价格比路由器低,所以组网成本更低。
第二因为交换机划分网段比路由器组网更灵活。
3.思考题:华为交换机有几种端口类型,分别有什么特点?

实验47-交换机接口类型
1.华为交换机上有几种端口类型?
三种:access、trunk、hybrid
access 接入端口 trunk中继端口 hybrid杂合端口
2.不同端口有什么特点
access接口用于链接终端设备,对于access接口而言只能允许一个vlan的流量通过
trunk接口用于连接不同的交换设备,对于trunk接口而言允许多个vlan流量
hybrid接口是华为特有的交换机接口类型,和trunk一样,可以允许多个vlan的流量通过,但是不一定用在交换机之间的连接上
3.trunk是如何区分不同vlan的流量呢?

实验48-配置trunk
1.创建vlan10、vlan20
2.将接口划入对应的vlan
3.配置trunk接口:
int Ethernet0/0/3
port link-type trunk
port trunk allow-pass vlan all
4.查看trunk接口:
display port vlan active
总结:
1.trunk链路为什么可以区分不同vlan的流量?
因为在trunk链路上交换机会启用802.1q协议,而802.1q协议导致交换机将报文从
trunk链路发送出去之前会将报文对应的vlan-id封装进报文中。这样对端交换机在
接收到报文后可以通过802.1q封装的vlan-id判断报文属于哪个vlan。

实验49-配置hybrid
1.创建vlan10、vlan20、vlan30、vlan40、vlan50、vlan60
2.配置hybrid接口,vlan10\30\50带标记,vlan20\40\60不带标记:
int Ethernet0/0/3
port link-type hybrid
port hybrid tagged vlan 10 30 50
port hybrid untagged vlan 20 40 60
总结:
1.hybrid接口与trunk有什么不同?
hybrid接口可以运行多个vlan的流量通过,但是不同的是hybrid接口可以
自己定义带标记通过的vlan和不带标记通过的vlan。

实验50-配置单臂路由
1.SW1创建vlan10、vlan20
2.SW1将接口划入对应vlan
3.SW1将连接路由器的接口配为trunk:
int Ethernet0/0/1
port link-type trunk
port trunk allow-pass vlan all
quit
1.R1配置单臂路由:

配置子接口
int GigabitEthernet 0/0/0.10
dot1q termination vid 10
ip address 10.1.1.100 24
arp broadcast enable
quit
int GigabitEthernet 0/0/0.20
dot1q termination vid 20
ip address 20.1.1.100 24
arp broadcast enable
quit

实验51-配置三层交换
1.创建vlan10、vlan20
2.将接口划入对应vlan
3.配置三层交换:
interface Vlanif 10
ip address 10.1.1.100 24
interface Vlanif 20
ip address 20.1.1.100 24

实验52-STP基础
1.STPP协议实现的功能是什么?
STP通过协议收敛使交换网络中任意两台设备之间有且只有一条可行路径。这样既可以避免单点故障问题,又可以解决广播风暴问题
2.STP的树形结构如何形成?
STP收敛过程中通过选举:根交换机、根端口、指定端口
从而实现STP树形成结构的收敛

实验53-STP根交换机选举